Show-n-Tell Thursday: Don’t Install Domino 7.0.1 if you’re using Blogsphere!

The real tip should say ‘Don’t upgrade without vigorous testing’.

The only way you are reading this is because you are using a RSS reader. You’re currently not seeing this with a web browser. Why? Because I’m now a member of the ‘Worst Practices Club’. I upgraded my Domino Server to 7.0.1 without testing my blog first. Now, when you access my site via http, you get:
Error 500 HTTP Web Server: Lotus Notes Exception – Incorrect data type for operator or @Function: Text expected
I got caught with a regression bug that happens in 7.0.1 that deals with DbColumn DbLookup and a 64KB limit. (Rocky mentions it and references others mentioning it here.)

Rocky mentions that a server side hotfix is available via the standard support channels. There will also be a client fix available soon.

For me, it looks like I’m going to be rolling back my server. I just don’t know when I’ll have time to do it…

Technorati tag(s): Show-n-Tell Thursday, SnTT, Lotus Notes, Lotus Domino

  • The problem is in two computed text entries in the D6.sidebars subform. I can mail you the code fix. Also you need to categorize a few lookup views (for category and calendar). The error trapping might become standard in 2.5.1. Christian is looking into it.
    I’m on 7.0.1 and Blogsphere 2.5.
    stw